İçeriğe geç

“Must override a superclass method” Hatası

Genellikle Eclipse’i tekrar kurunca bazı projelerde “The method onClick(View) of type … must override a superclass method” vb. şeklinde hatalar oluşuyor. Aslında kodda bir problem olmamasına rağmen böyle bir hatanın oluşmasının temel nedeni Eclipse’in varsayılan ayarları. Yeni kurulum yapılan Eclipse’te varsayılan Java ayarı 1.5 olarak gelmektedir. Bu hatayı aldığımız projeler ise büyük ihtimalle 1.6 ve üzeri Java versiyonlarında oluşturulmuştur. Bu yüzden yapmamız gereken işlem projemize sağ tıkladıktan sonra Properties -> Java Compiler menüsünden “Compiler compliance level” i 1.6 veya daha üst bir versiyona çekmek olacaktır.

İyi Çalışmalar.

Tarih:AndroidEclipseGenelProgramlama

İlk Yorumu Siz Yapın

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

%d blogcu bunu beğendi: